Problem z sumowaniem godzin 24h Excel

Porada dotycząca rozwiązania problemu przy dodawaniu czasów (godzin), których suma przekracza 24 godziny. Przykład takiego nieprawidłowego obliczenia pokazany jest na poniższym rysunku – tygodniowym harmonogramie czasu pracy.

Problem z sumowaniem godzin w Excel - screen1

Obszar C3:C7 zawiera czasy, które przedstawiają liczbę godzin i minut przepracowanych każdego dnia. Formuła w komórce podsumowującej jest następująca:

=SUMA(C3:C7)

Problemem jest to, że formuła daje wynik w postaci numeru seryjnego daty, równy 1,680555556, ale formatowanie komórki powoduje, że nie jest wyświetlana część odpowiedzialna za dni.

Problem z sumowaniem godzin w Excel - screen2

Aby móc zobaczyć prawidłową wartość czasu, który przekracza 24 godziny, należy zmienić format komórki. Część oznaczająca godzinę należy ująć w nawias kwadratowy. Użycie poniższego formatu spowoduje, że suma wyświetli się prawidłowo:

[g]:mm

Zmiana formatowania oraz poprawny wynik (suma godzin) prezentowany jest na poniższym screenie.

Problem z sumą godzin - formatowanie komórek - screen3

 

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *